Take the 2-minute tour ×
Bicycles Stack Exchange is a question and answer site for people who build and repair bicycles, people who train cycling, or commute on bicycles. It's 100% free, no registration required.

I'm using Hayes CX-5 Mechanical Disc brakes with Avid The G2 CleanSweep Rotors on my cross bike. I believe the Pads that come stock with Hayes CX-5 brakes are semi-metallic.

I'm experiening uneven braking, it's really a pain to feather my braking to slow down because of this. It seems that the brakes engage on parts of the rotor, but seems to slide more freely over other sections. I wind up over braking to slow because of this. The rotors are a month or so old and do not appear to be visibly bent at all.

What is causing this? How can I even out the performance of my braking?

share|improve this question
3  
Does this problem exists on both brakes (front and rear) or only in one of them? Also, did you try cleaning your discs with rubbing alcohol or a similar solvent? –  Jahaziel Sep 27 '13 at 16:15
    
Sounds like warped or poorly machined rotors. –  Daniel R Hicks Sep 29 '13 at 11:22
    
Seems like just the front brake currently. I've cleaned it once with solvent. I'm going to clean it again and ensure whether it has been bed in properly and report back. –  Benzo Oct 1 '13 at 16:57
    
Cleaned rotors and Attempted to do hard braking to bed in the rotors more. Still a touch uneven, but much better than before. Going to try to do some more hard braking down hills and see if it continues to improve. –  Benzo Oct 2 '13 at 13:45
add comment

1 Answer

up vote 2 down vote accepted

You say the rotors are relatively new. Have they been bedded in properly? The usual procedure is to get up to about 30km/h, brake hard until you almost stop, and repeat. You should feel the braking power picking up each time you do so.

The bedding in process transfers some pad material to the rotors - this is what the pads grab, rather than the actual steel surface. It should be done any time rotors or pad compounds are changed.

share|improve this answer
    
Cleaning and bedding in the rotors seemed to do the job. Apparently the original bedding in wasn't through enough. A good cleaning and laying on the brakes going downhill a few times got the brake response working normally. –  Benzo Oct 16 '13 at 17:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.