Take the 2-minute tour ×
Bicycles Stack Exchange is a question and answer site for people who build and repair bicycles, people who train cycling, or commute on bicycles. It's 100% free, no registration required.

I've noticed several times lately when stopping at an intersection with a car detection loop that my wireless cyclometer (an Atom 4.0) exhibits some strange behavior. It continues to think I'm moving (as indicated by a triangle icon), the distance increases (by a tenth of a mile every few seconds), the average speed goes up rapidly (in accordance with the distance increase), but the current speed appears stuck at whatever the last real reading was, and the maximum speed is unaffected.

I suspect it's to do with the car detection loops in the pavement, since the only other electronic things on my bike are lights, and I've seen this with them off. Is this how interference might present itself in the cyclometer? Are the loops indeed a probable source? Can I try to shield something to avoid it?

share|improve this question
3  
Interesting question. The detection loops are a induction loop that creates and detects current flow in conductive (metal) materials. Cyclometers are typically a coil that picks up a magnet going by (which causes an electric pulse). Certainly seems possible that an induction coil could cause a current flow in the cyclometer pickup, but I just don't know. Hopefully somebody does. –  freiheit Jan 18 '12 at 18:10
    
@freiheit: Well, that current is induced by putting a signal into the loop (Wikipedia says 10-200kHz). I'm not sure how the signal from the magnet passing is detected, but it seems like the distinguishing component would be at a much lower frequency (even though it'd have higher-frequency components), so I'm not sure if it could interfere there. It's also possible it could be directly affecting the computer; I don't know what the sensor-to-computer signal looks like. –  Jefromi Jan 18 '12 at 18:39
    
I'm surprised it's that sensitive. I've not noted that behaviour from any of my cyclometer. Nor from the rally computers on my cars (which is basically the same type sensor as a cyclometer). In my case, they're all fully wired (I'm not a fan of wireless unless it's absolutely required for an application). –  Brian Knoblauch Jan 19 '12 at 14:32
    
Solution is to buy a digitally coded cyclometer. Sigma, for example, makes cheap-ish ones that are quite good. –  Stephen Touset Jan 19 '12 at 14:37
1  
@StephenTouset: Sure. I just figured a piece of aluminum foil in the right place was a lot cheaper. –  Jefromi Jan 19 '12 at 16:14

5 Answers 5

For what it's worth, I'm completely certain now that it's the vehicle sensing loops causing the strange cyclometer behavior. It also seems to be directly interfering with the cyclometer itself, nothing to do with the sensor - I've seen it happen when the sensor wasn't on the bike. There are several intersections where I can reliably make this happen by stopping over the loops - and many more where it never happens - so it seems to have to do with the specifics of the loop, too.

share|improve this answer

thought somebody might be interested in this, I own a cheap repco bike computer ($20) and after removing the display unit from my bike and placing it next to my ipod i discovered it saying i was riding again. Upon moving it away from my ipod i noticed it stopped. This happened for multiple electronic devices in my home including computers and mp3 players (even tv's). I am absolutely dumbfounded to why this is doing this. I know it's not on topic but it is very interesting is it not. if anybody knows why this is happening please enlighten me.

share|improve this answer
    
The ANT interface is not too sophisticated, and an iPod or similar electronic device radiates a lot of RF energy (relative to its size, at least). In particular, an iPod has a WIFI radio in it that operates in the same 2.4 GHz band as ANT (ANT uses a primitive subset of the WIFI protocol), so the ANT receiver could very well interpret iPod transmissions as wheel pulses. –  Daniel R Hicks Apr 5 '12 at 11:54

I don't go over the things too often, but I've never noticed this with a wired unit (haven't had my wireless long enough to really notice this, since I don't do that much city riding).

The interference could work two ways. Could be interfering with the wireless radio (which I suspect is ANT, a sort of poor-man's Bluetooth), or it could be that the pulses from the induction loop are triggering the reed switch pickups (or perhaps they use Hall-effect sensors in the newer units).

Whatever the interaction is, it is a bit weird -- Wikipedia says that the typical loop frequency is 10 kHz to 200 kHz. But unless it's pulsed it's hard to see how it would affect the sensors themselves, and ANT operates at 2.4 GHz and should be pretty much immune to the loop frequency.

But the way you say it behaves -- getting "stuck" at the last valid speed reading -- is even more bizarre. My understanding is that the ANT transmitter pulses for each turn of the wheel, and one would expect interference to register as regular pulses, generating a speed that's fixed for a given loop but not related to your former speed.

This points to the 3rd possibility that the cyclometer employs a phased-locked loop of sorts to filter "noise" from the speed pickup, and the induction loop is simply overloading the cyclometer receiver to the point that it detects continuous noise. In this situation the phase-locked loop would tend to maintain it's former reading, and you would likely see the phenomenon of a "stuck" speed reading.

In any event, more and more of the intersections around here use cameras instead of induction loops, so such interference is getting less likely (for me, if not for you).

share|improve this answer

The car induction loop seems to be the most likely culprit. Their operation rely on an induction coil being buried under the street in front of the lights [1]. When it detects a car, or for that matter your metal bike, as a result its magnetic field is increased. This magnetic field is used for operation of the lights, but its conceivable that the field will affect the operation of your wireless comp. It's questionable if it would affect a wired computer, as it would be shielded with the connecting cable.

When passing through the door in my local bike shop with my bike while having my cyclocomputer fitted I also see the same affect. This time its down to the anti-theft magnetic detection loops fitted at the door. [2]

I suppose the solution is to fit a wired comp instead. Or else make sure you stay well back from/in front of the lights.

[1] http://auto.howstuffworks.com/car-driving-safety/safety-regulatory-devices/question234.htm

[2] http://en.wikipedia.org/wiki/Electronic_article_surveillance#Magnetic_systems

share|improve this answer

I've found the same thing happens to me when using the wireless ones. Was never sure if it was the fact my wife was riding so close to me and we had cross talk happening, as she has the same model as me. Figured that if my reciever was picking up my transmitter and her's slightly later then I would start seeing a double in my speed, which is sort of what I have seen.

The idea of it being the induction loops never occured to me...as I don't fully understand the circuit being used for the sensor I'll reserve judgement on that.

share|improve this answer
    
Interference from the same kind of cyclometer is a definite possibility for you, but for me, it's definitely not the cause, since I've observed this with no cyclists anywhere near me. –  Jefromi Jan 19 '12 at 3:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.