7

Recently I've been getting notifications on my edge 510 of an upcoming segment (& and display when riding through it) - I can turn this off by hitting the red cross on screen when it comes up, but I'd like to completely disable this function and can't work our how. Any ideas?

  • I don't have a Garmin, but it sounds like you're following a course, or doing a workout. See the manual. – andy256 Jun 11 '15 at 23:40
  • I think you'd have better luck with Garmin's support forums. forums.garmin.com/forumdisplay.php?363-Edge-510 – Carey Gregory Jun 11 '15 at 23:41
  • @andy256 it's affecting any ride (I rarely preloaded routes) – rg255 Jun 12 '15 at 5:46
  • @andy256: No, there's no need to follow a course or do a workout. If you have a segment uploaded to the device, the segment will trigger this "segment mode" display every time you ride through it. Another annoying issue with this functionality is that the "segment mode" screen will also pop up when you ride through that segment in reverse direction. – AnT Jun 12 '15 at 21:27
  • @AnT Sounds frustrating! I think I'm happy I don't have one :-) – andy256 Jun 12 '15 at 22:21
5

This works with firmware 5.0.

From the start screen, click the "folder" icon on the bottom left

Click "Strava Live Segments"

Click the Menu button on the bottom right (the three rows)

Click "Disable all"

| improve this answer | |
2

In Garmin connect, you can disable segments and then synch the 510.

Have you created your own segments? On the 510, you can go to segments under the folder menu, go to the very bottom option and choose delete all segments.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.