1

I have my Giant Talon 4 2016 with Tektro hydraulic brake system. For a month or two I stopped riding and today when I used it, my front brake doesn't seem to work properly. I mean, the brake applies, the pad also seems to be grabbing the disc as its supposed to, but the brake is sloppy. Am I missing something here? Any help is appreciated. Thanks,

1
  • Did you park it up somewhere safe or was it left outside? Cat piss is a possible contaminant for disk brake pads, but they generally can't aim high enough to get rim brake pads.
    – Criggie
    Aug 2 '17 at 23:22
2

There are a few possibilities that come to mind, but there may be others:

  1. If the brake pads have been contaminated by something, such as oil or a lubricant, they’ll be almost useless. The pads will move in normally and at the lever the feeling will be of the pads making good contact, but they will be pretty ineffective in slowing you down. You will need new pads.
  2. If there is air in the hydraulic system the lever will feel spongy, so it won’t bite very well. The pads will move in and make contact, but you’ll be able to keep pulling the lever a bit more, and they won’t be as powerful as they should be. You will need to bleed the system to remove the air.
  3. If the brake pistons have been moved outwards, away from the rotor, the lever will move further than it should before the pads make contact with the rotor. This could have happened if the pistons were pushed outwards by the rotor when installing the wheel, or just by normal flex in the frame, fork, and wheel when riding causing the rotor to push the pistons. To fix this, try removing the wheel from the bike, then giving the brake lever one gentle pull about 1/2 or 3/4 of the way through its travel. Hold it there for a few seconds and then release. Then reinstall the wheel and try again. You may have to force the pads apart a little to fit the rotor in again if the pistons have moved too far inwards. If they didn’t move far enough you may need to repeat this a couple of times, pulling the lever slightly further each time. Be careful not to overdo it. If you have had to move the pistons in a long way you may need to top up the system with some more brake fluid. Be sure to use the correct fluid for your system.
1
  • Thanks for the elaborated info. I will be sure to check them all out and accept the answer after i find the problem. Aug 2 '17 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.