0

Weird problem. My mtb makes this clicking noise at the same spot when i pedal. It sounds like its coming from the crank but if i backpedal it goes away for about 5 minutes and then comes back. Is it a locked up link on the chain? It's making me crazy. Any help would be appreciated. Thanks.

  • 3
    Spend a little time studying prior posts here. (Hint: Look at the "Related" list to your right.) There are a half-dozen possible causes of your noise. – Daniel R Hicks Jul 30 '18 at 1:37
  • 3
    Possible duplicate of Clicking feeling when I pedal – Argenti Apparatus Jul 30 '18 at 12:15
  • Not a weird problem at all - judging by the frequency of questions about it on this site. Check the previous question and answers this s flagged as a duplicate of. FYI, as click is one per rev of cranks it's not the chain as a bad link would not come round every time. – Argenti Apparatus Jul 30 '18 at 12:18
1

Probably not a link of the chain. It really can be anything, but I bet it is on the crank arms, bottom bracket or even the crankset in itself. You should take your bike to a trusted mechanic, clearly explain your issue and make him ride your bike and feel the noise. It is probably something loose or a bit out of place.

1

If it were a locked up link on the chain, you would not hear the sound on every rotation but only when the link came around again.

I had this exact problem last week. Ended up removing the crank, unthreading the bottom bracket and cleaning everything up. I also re-torqued the bolts on the chainring. Lucky for me the sound went away.

As others have suggested, check the pedals and bottom bracket. Make sure everything is torqued correctly and clean.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.