0

So I popped my tire manualing down a curb and I went to patch it but I didn’t seem to have any glue left in my old tube of glue, so I went to the bike store and bought a new thing patch kit(cheaper to buy a new kit then a thing of glue) and I get home and go back to fixing my tire, I used the cap of the glue to pierce the top, I then tried to squeeze some glue out and heard a popping sound, I squeezed some more and there wasn’t any glue in the brand new tube of glue I had just bought and opened. Did the bike store rip me off? Or did I do something wrong?

  • 2
    The store didn't make the patch kit, so they didn't rip you off. Manufacturing errors happen. Check there really isn't any glue (or substantially less glue than there should be) and take the kit back to the store and ask for a replacement. – Argenti Apparatus Sep 7 '19 at 20:52
  • It's not uncommon for there to be a large bubble of air in there, but, if you place the tube on a flat surface and press it flat, starting from the "tail" you should be able to get a reasonable amount of glue out. If not, return it to the store for replacement. – Daniel R Hicks Sep 7 '19 at 21:49
  • 1
    Could have been old stock where air had got through the seal and set all the vucanising fluid. – Criggie Sep 8 '19 at 4:16
6

If you buy something from a shop and it doesn't work, take it back and explain what happened. They'll almost certainly offer you a refund or a replacement.

|improve this answer|||||
0

I’ve had this happen with very old glue. I think the shop will understand the issue and replace it.

|improve this answer|||||
0

You can get small tubes of glue the same size as is in a patch kit. Some stores sell them, some don't, but they should be cheaper than a whole patch kit. They're also available mail order -- you can get a whole pile of them cheap. You can also get a larger can as well. The small tubes are nice tho because, when opened, the glue dries up quickly. This can happen even when they're unopened, as you found out. The glue in the kit you bought likely had a defective tube and it dried up while sitting on the shelf. Hopefully the shop replaced it.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.