3

I have a cheap velo cycle computer made by cateye. It is a simple read out of velocity and clock and has no fancy functions at all.

It worked fine for months, and then started "blipping" to double my speed. That is, if I was doing about 20 km/h it would blip to 30 or 40 or 60 and then drop back to my real speed. I disregarded this and keep riding.

A month later it starts cutting out, reading 0 km/h or numbers like 6 or 9, where I am riding at about 20 km/h on the flat road.

I check closely - battery is okay but I change it anyway. No water anywhere, no rust, no damage, nothing wrong.

Now it stops completely - only shows a speed for a few seconds then back to 0.

The clock works fine, shows the correct time all the time. Head unit has not been dropped. Yes it has been ridden in the rain but that is what these are designed for and there is not water mist inside the screen.

How do I troubleshoot my bike computer? I know is not a Garmin or wahoo or any flash thing, but is only a year old. Probably out of warranty and I want to learn how tofix it. Or to stop from breaking the next one.

Computer is like this one https://www.chainreactioncycles.com/nz/en/cateye-velo-5-function-computer/rp-prod26194 with wires, not cellphone or GPS.

6

First of all, try changing the distance and vertical alignment between the sensor and the wheel-mounted magnet.

If that doesn’t help, the sensor (or its cable) mounted to the fork is probably broken. Check the cable for any visible damage. I think the sensors are usually cheap&simple reed switches to detect the magnet. If you have a multimeter you could try measuring the resistance between the two contacts of the cycle computer’s mount. It should toggle between zero and infinity when you pass the magnet in front of the sensor. If it doesn’t do that it confirms a sensor or cable defect.

Your best choice is a replacement part, but if you are handy you could try replacing the cable and/or the reed contact.

4

I've been through this exact situation with a Cateye Velo 7 and it did very similar things. I'd be riding along at 30 km/h and the speedo would flash to 45 or 60 and rarely 90, and I never saw it but the MAX SPEED was at 120 km/h.

The curious thing about those numbers is they're some multiple of the speed I was travelling.

Firstly, start by checking the magnet. Its probably fine, but this is far and away the easiest thing to check. Most sensors have a line that is the middle of the sensor, so that's where the wheel magnet should be centered.

Otherwise, your description tells me the wiring is mostly working but the head unit is getting multiple signals. The possible causes here are

  1. a break in the conductor inside the wire
  2. an intermittent connection to the head unit inside the socket on your bars
  3. poor quality soldering at either end of the wire - a cold joint
  4. a faulty sensor
  5. extra magnets on your wheels.

The extra pulses mean that something is blipping more than once per wheel rotation. I'm not sure exactly how many blips the headunit requires to calculate a speed, but from manual testing its at least 3, maybe 4.


If you think the head unit might be acting weird on its own, test it out of the harness using anything metallic to short the two pads on the back. (note the pictured connectors are dirty and need a clean.)

From https://softsolder.com/2010/09/18/bicycle-computer-failure-its-the-connector/

Rapid shorting of these pinheads should make the computer see wheel rotations, and give an approximate speed.


You can troubleshoot the harness too - connect a continuity sensor (either a multimeter with a beeper, or an ohmmetermm or a small lightbulb and battery) to the pads on the receiver socket, the plastic holder that stays clamped to your bars.

The reading should be infinite ohms, which means no connection.

Move a magnet past the sensor, and this will close the internal reed switch, which will make your meter beep, or the ohmmeter read a number, probably about 1 ohm. This should go open circuit again when the magnet is removed.

If this doesn't work, examine the wire for any bumps or sharp folds or abrasions. Any should be repaired and then continue troubleshooting.


Down at the sensor, if you can pop the unit open and see the reed switch then do so. There may be fasteners or clips or perhaps simple friction holds it shut. In mine, there was a small black plastic version of a "guttering downpipe standoff" which clipped over two plastic studs and held a tiny circuit board in place.

I did not get a photo sadly, but the only component on the board was a through-hole reed switch and two holes for the wire to attach. My reed switch was faulty, so I replaced it with a $2.50 item from the local electronics supplier and it worked fine. A dab of solder and some glue were the only other parts used.


Note when reassembling, use glue to provide sealing from moisture, and to reinforce where the wires come out of plastic - generally these are prone to breaking here.

Use creative wrapping around a brake cable or similar to get your wire up to the handlebars while supported.


I do not think its your battery, because the screen will start going dim when the battery needs replacing.

Most of the wired cateyes use the same mount and sensor, which is available as a spare part. Downside of this is the spare part is $18NZ from Wiggle, whereas the whole unit is only $22. For the difference I'd rather have a spare headunit for $4.

  • 4
    Your post raises a point -- first try just sliding the meter out of its socket and putting it back, to clean the contacts. If this fixes it, go to an auto parts place and get a tube of "ignition grease", and put a tiny blob on each contact. The special grease helps prevent oxidation of the contacts. – Daniel R Hicks Oct 6 at 19:13
2

My experience with cateye computers (admittedly only with a small sample size of 2) is that the mounts are not very sturdy, and after a few months develop enough play that the unit can 'rattle' within the mount when going over less than perfect surfaces.
In the case of this particular model, that would cause the contacts to make/break and potentially create 'fake' sensor pulses. In my case I resolved it by padding out the bracket to create a tighter fit, but it wasn't a great solution and I replaced it with a gps computer (which have their own issues) shortly after.

  • did you move the headunit around a bit? Or frequently disconnect it from the socket? – Criggie Oct 8 at 5:18
  • 1
    @Criggie Yes, the head unit was connected/disconnected every time I rode - didn't leave it on the bike. No doubt that accelerated the wear process. – Andy P Oct 8 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.