2

I have a Norco Mountaineer SL. It has a schrader valve and I am trying to inflate the tyres using https://www.amazon.ca/Crank-Brothers-16304-Sapphire-Silver/dp/B07K4PLWKW/

I seem to have set it up correctly for schrader valve. The air comes out of the pump head when I pump it. It seems to adjust on the bike valve fine. I then lock it and try to start pumping. The gauge moved the first time I pump and then remains at the same pressure. The air does not get into the tire remains stuck in the head/pipe of the pump and it then gets squeezed out when unplug it from the bike valve. How do I fix it?

I have tried moving the rubbers in the head of the pump but it seems to be squeezing air out just fine. I am not sure why is it not getting into the tyre AT ALL (Tried both tyres)

  • 2
    Usually this is because you did not shove the chuck all the way onto the valve stem. – Daniel R Hicks Jun 6 at 12:35
  • Does your tyre have sealant inside? Sometimes that fluid can jamb up and block a valve if there's a slow leak at the valve. – Criggie Jun 6 at 23:28
1

The pump looks fine. You should fiddle with the pin in the valve (tap it a bit with a screwdriver) until it leaves some air out (dose your tapping from "just a bit" to "try to firmly push the pin inside the tube").

If nothing cames out, try to spray some wd40 on the valve.

If nothing, it may mean the valve is really stuck ... did you use some foam or similar products to fix a puncture?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.