I went for a ride in Zwift, afterwards, I thought I'd check for firmware updates, there was one, I flashed it, disconnected the bike from the computer. I then swapped out a cassette, went into change the size in the etube app again. It connected without issues, though I got distracted and had to step away for a bit.

When I came back, etube wasn't able to connect to the bike. I unplugged it, and tried to reconnect but still nothing. I thought maybe that the bike needed a charge, so I let it sit plugged into the wall for about an hour, this didn't seem to improve things.

Right now, I am not seeing any lights on the junction box, I tried crash mode without success. Are there any other troubleshooting steps I can try? The R8050 dealer manual wasn't super helpful.

I'm worried I may have bricked the system.

  • Check the connectors, there's quite a number, some hidden ones as well.
    – Carel
    Feb 28, 2021 at 16:03

1 Answer 1


Turns out that an unnoticed connection from the e-tube app on my ipad blocks any type of connection via the e-tube app on my laptop, charging, or usage generally. So after you've checked all the connections, attempted crash mode, let it sit charging, make sure that you've 'disconnected' any device in the etube app that may have inadvertently connected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.