I am trying to bleed my SRAM HRD (from Red eTap groupset) brakes for the first time. Did everything according to the manual (adjusted brake contact point on lever, caliper bleeding port is open, etc) but I cannot push DOT fluid from the lever syringe to the caliper one, something is blocking it.

If I push REALLY hard, the lever starts compressing which means the lever bleed port is open. If I compress the lever fully with my hand, I can see a bit of fluid entering the caliper syringe which means the caliper bleed port is open. Yet I can't push fluid "down" to the caliper with a syringe using "reasonable" force.

The brake system is completely stock, no hose shortening was done. It has never been bled (in 3 years).

What are the things I could check to help me solve the problem?

  • 1
    The manual states there is a bleed screw at the lever, that needs to be removed (t10 torx) One of the syringes goes there. To me, your descriptions sounds as if you missed that step. Other than that: when you do that job for the first time, it is likely you accidentally skipped a step. Start again from the beginning, most likely you will see which step you missed.
    – Burki
    Commented Jul 8, 2022 at 12:48
  • @Burki I do have the lever bleed screw removed and the syringe connected. Both bleed ports are open for sure.
    – Misterer
    Commented Jul 8, 2022 at 13:01
  • 1
    Have you opened the clips at the hoses of both syringes? And have you tried checking if you followed every step in the manual?
    – Burki
    Commented Jul 8, 2022 at 13:03
  • Yes, both syringes are unclipped. That's the thing - this isn't rocket science and there aren't many steps to do before the bleeding procedure. I wonder if there's a hose blockage somewhere in the system.
    – Misterer
    Commented Jul 8, 2022 at 13:09
  • 1
    if you have the clips on the syringe, move them up or down a bit and massage the clamped area. They get sticky/stiff when not used for a while. You are right in saying the lever can produce significantly more force than the syringe. Have you ever tried braking with a syringe!?
    – Noise
    Commented Jul 8, 2022 at 15:20

3 Answers 3


SRAM/Avid bleed kit hoses are known to get kinked from the clamp pressure, which can sometimes result in issues where fluid can't pass through the system even though everything is set up right. To check for this, move the clamps on the bleed hoses off from the area they were previously clamping, and squeeze/pinch the hose until it's nice and round again and you can clearly see that it's unobstructed inside. This could still be what's happening even if it's a new kit.

Brake systems can develop blockages and at some point once you've eliminated other possibilities, that becomes the next thing to look at. Sometimes it can be a partial blockage or a piece of debris that acts a little like a one-way valve, but in a partial or erratic way that makes logical troubleshooting difficult.

If the hoses were set up with Connectamajig, I've heard of situations where the piercing mechanism it uses has problems with acting as a one-way-valve. You could get to a point with this where you troubleshoot whether fluid is moving freely through the hose itself in both directions, and replace the hose if not.

  • 1
    I had some Avid Elixirs do the same thing to me - some how generated a one way valve between the reservoir into the master cylinder. Fix was super easy, replaced with Shimano.
    – mattnz
    Commented Jul 9, 2022 at 0:29

I figured out the problem. I had overtightened the brake contact point adjuster screw. Loosened it (quite a bit actually) and now the fluid can pass through.

If only this little detail would have been included in the manual as a warning...


I’ve had the same issue - disassembled everything and fluid would flow from every point except for from the hood into the line through the stealamagic or whatever. Thought I possibly broke the internals of that piece when I twisted it during removal of the line initially to thread the line through the frame but it turned out the red olive was the wrong size which was the reason it would only thread on to the barb 1/2 way. Once I got the right sized olive, I was able to slide the unthreaded part over the barb and then screw the olive on resulting in the opening of the barb and the opening of the olive being flush with each other. The fluid then moved as it should. Not a complicated process in retrospect if the pieces would’ve been compatible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.