0

a long time reader here that was usually able to find an answer, but not on this one. I've done some basic and slightly more advanced fixes and part replacements on bicycles, but I've never installed and bled hydraulic brakes. The brake lever is the GRX BL-RX820-L and the caliper is the BR-RS785. I've followed the Park Tool guide almost to the end, but the problem is the lever is so soft it's almost like it was when the system had no fluid.

I stopped in the part near the end when it said to quickly open and close the screw on the bleed nipple, release the lever and repump until firm. At this point I noticed it's actually not really doing anything. I tried to let it drip further, but this had no effect. I removed the bleed blocks in the end and pressed the lever just to see what's happening, and there is some minimal movement on the pistons, but really weak.

As a first step I'll try to go back and start from scratch, but wondering if there's an obvious thing I missed.

One thing that made me unsure for a while was that the left lever always had a little click when I tried it. The right one was always smooth, but the left one made a little click before it reached the handlebars. I figured this will not be a problem as the lever will have that much travel, but maybe something is broken.

I appreciate the help!

Here are some more infos and the steps I did:

  1. the parts are new. I just went through the guide again and think I did everything as described, but obviously I could be wrong. It was also my first time installing the hoses and I checked in the end, but did not see any leaks
  2. I injected the fluid through the caliper and it went up fine to the funnel
  3. I then filled the funnel some more and let the oil drip down, it said to press the levers gently, which I did (now that I write, I can't remember how the lever felt at that point). There was never a point where the funnel emptied
  4. it seemed ok, I did not see any bubbles coming out of the caliper anymore so I closed the screw on the bleed nipple
  5. then it said to press the lever and hold, quickly open and close the screw, let go of the lever and repump until firm, which is where I stopped
2
  • Hard to diagnose from afar. Perhaps take a video of the last step before, i.e. the draining into the disposal bag. Before attaching the bag, check whether you can feel pressure on the lever (with the bleed valve closed).
    – Erlkoenig
    Commented May 10 at 6:39
  • I redid the whole thing and it got better. There is pressure after just injecting from the bottom. Weird issues still appear in the part with the quick open and close. The part where you repump kind of works in the end, but I don't know how. There is oil in the funnel and oil in the hose on the caliper, but when opening+closing the pressure is lost and I press the lever but there's no pressure until it somehow magically appears. I haven't figured out yet what happens. Simply pressing the lever doesn't work.
    – nomve
    Commented May 11 at 22:19

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.